AEGIS Mini

Discussion in 'General Hardware Discussion' started by crispernator, Dec 15, 2018.

  1. crispernator

    crispernator Senior Member

    Joined:
    Dec 9, 2015
    Location:
    adelaide
    Well as i stated in another thread i have just purchased and aegis mini ,it has a built in battery which is a bummer but i like the aegis i have but it is to heavy to carry in my pocket of my shirt so i have this one . Now it comes with a super little sexy tank the strangest coils i have ever seen a spare glass, spare seals ,charging cable ,spare coil instruction manual and some other paperwork .
    One thing i have found is that when you leave it for a while and try to fire it you have to tell it if it is a new coild or the old coil ,normally on the agis this will only happen if you change the battery over but the mini seems to have this as a achilees heal so to speak ,i will speak to my local and see what he says maybe it needs to be set up as i just set the watts and started to puff away anyway i am happy with it so far just this one small nigel comes in blue red green camo and silver and tan i think some may say it is going backwards but it suits me and it has all the features of the aegis and aegis legend check it out .
     
    emu likes this.
  2. Davo

    Davo New Member

    Joined:
    May 12, 2019
    Location:
    Sydney
    I also have the aegis mini (as well as the legend) but haven't had the same issue you describe. The only issue I have had is the coils that come with it not lasting more then a few days but I think this has been due to the small wicking holes and trying to run them at to high of a wattage. I'm not sure what I have done that could have been different to you but good luck in getting it sorted.

    P.S I got the black one with red stitching.
     
  3. Noe

    Noe Adorably quirky ... QUIRKY Noe! VCA Approved Post Whore

    Joined:
    Jun 2, 2015
    Location:
    Noewhere
    I have the Aegis Legend & I have an issue where it sometimes on some presses of the fire button drops a few 0.0? of an ohm. Most times it reads correctly & I've tested on my DNA devices with the same tanks, which have no similar issues.
    I think its just a bit of mass produced lottery going on here, where some chips are fine & others have glitches.
     
  4. Davo

    Davo New Member

    Joined:
    May 12, 2019
    Location:
    Sydney
    I have noticed on both of mine the ohm's drops by 0.01 after I've used the coil for a day or so and have seen a review on the youtubes (I think it was the Mike Vapes review of the aegis mini) where he says the the chips are sensitive to ohm drop and will ask the new coil question when the mod is switched off and back on but yeah this hasn't been an issue for me.
     
  5. Noe

    Noe Adorably quirky ... QUIRKY Noe! VCA Approved Post Whore

    Joined:
    Jun 2, 2015
    Location:
    Noewhere
    That is somewhat normal behavior which happens as a coil gets used over time & gunked up.
    The ohm drop I get is between button presses of the fire button, on a new coil eg. it will read 0.21 ohm on the first press, the second & third presses also, then on maybe the fourth or fifth press it will read 0.18 ohm ,then on the next press read 0.21 ohm again. There is no set pattern to it, it seems to be semi-random & I'm not sure what the cause is, all I do know is that the build in my tanks is stable on my DNA devices.
    Don't get me wrong I like the Aegis Legend but I don't entirely trust it either, my DNA 250's I have complete confidence in. The Aegis is great for when I need a waterproof/shockproof device but it isnt my "go to" for all day use.
     

Share This Page